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Course Overview

Course Description

This course is designed to teach a 2D production drafter how to use MicroStation 
software to create quality designs. You will learn to use MicroStation#s tools and 
features to create designs, manipulate and modify elements, assemble project 
data, and create printed output.

Target Audience

This course is recommended for the following audience(s):

$ Individuals who are learning how to use MicroStation for the first time

$ Those who are moving to MicroStation from another CAD application

Prerequisites

$ Fundamental knowledge of the Microsoft Windows operating system

Course Objectives

After completing this course, you will be able to:

$ Create and edit files that contain elements such as lines, circles, and polygons

$ Manipulate and modify existing elements

$ Annotate designs

$ Organize data

$ Print
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Getting Help

Getting Help

There are several ways to get assistance while working in MicroStation. Find 
options on the Help menu on MicroStation#s main menu bar, which is at the top of 
the MicroStation application window.

$ Select Contents from the Help menu to open the MicroStation help 
document. You can browse topics, use the index, and perform keyword 
searches.

$ Help is context-sensitive: Pressing F1 while using a tool or dialog box will open 
the help document directly to the topic related to your current task.

$ You can turn on the help Tracking feature to automatically display help for 
each newly selected tool. To do this, select Tracking from the Help menu on 
the main menu bar.

Quick Start Guide

Selecting Quick Start Guide from the Help menu opens a PDF document that 
provides a brief overview of some of the topics and concepts contained in this 
more detailed course.
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Welcome to MicroStation

Module Overview

This module will help a new user become familiar with the tools and features 
found in the MicroStation design environment.

Module Prerequisites

$ Fundamental knowledge of the Microsoft Windows operating system

Module Objectives

After completing this module, you will be able to:

$ Identify features in MicroStation#s interface

$ Use basic mouse functions with MicroStation

$ Create new files and open existing files

$ Save file settings

$ End a MicroStation session

Introductory Knowledge

Before you begin this module, let's define what you already know.
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Launching MicroStation

Questions

1 Provide a definition of computer-aided design.

2 Name three simple graphical elements that you might use to create a 
computer aided design.

3 Describe the basic parts of an engineering design.

Answers

1 The term CAD defines a system that a designer/drafter/engineer can use 
for both designing a product and for specifying the construction 
processes.

2 Lines, circles, arcs, polygons.

3 A border and graphics that make up the design.

Launching MicroStation

You can launch MicroStation using one of the following methods:

$ Select the Bentley program group from the Windows Start menu (Start > (All) 
Programs > Bentley), then select the MicroStation item

$ Double click the MicroStation icon on the desktop

$ Double click the icon of a .dgn file in Windows Explorer

The default installation location on Windows XP is \Documents and Settings\All 
Users\Application Data\bentley\MicroStation.

On Windows Vista, the location is \ProgramData\Bentley\.

On Windows 7, the location is \ProgramData\Bentley\.

Note: The ProgramData folder may be hidden. To display it select Folder Options from 
Windows Explorer#s Tools menu. Select the View tab and enable Show hidden 
files and folders.
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The File Open Dialog

The File Open Dialog

When you launch MicroStation, the File Open dialog appears. Its primary function 
is navigating to and opening design files.

To list a specific type of file, click on the arrow next to the Files of type field in the 
lower portion of the dialog. A list of all available file types will be displayed. When 
you select a specific file type, the files listed above will only contain those that 
have the selected extension.

The functionality you associate with native Windows file selection dialogs is 
available. For example, you can right click on listed files to rename and delete 
them, create sub-folders, display file sizes, types, and modification dates, and 
change the file list sorting order.

The preview window on the right side displays a thumbnail image of the selected 
file if one is available. If the file is from an earlier MicroStation version, a 
thumbnail is not displayed. Information about the selected file appears above the 
preview window. The information indicates whether a DGN file is 2D or 3D, and 
indicates the MicroStation version with which the file is compatible. The file 
format version displays for AutoCAD files. 

Thumbnail images are generally available for MicroStation V8 generation files and 
for later versions of the .dwg file format.

Thumbnail File Association

V8 generation DGN files and later revisions of .dwg files

V8 generation  DGN files and later revisions of .dwg files, when a 
thumbnail is not available.
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The File Open Dialog

Check the !Open as read-only" check box at the bottom of the dialog so that files 
will open in a read-only mode for viewing and printing. This protects you from 
accidentally modifying a file.

Workspaces

A workspace is a custom MicroStation configuration that is set up by an 
administrator. By selecting a workspace, you customize MicroStation for a specific 
discipline, project, or task.

MicroStation is delivered with a sample workspace containing example files, 
which show many MicroStation features. When a workspace is active, the files 
and tools you need to perform specific design work are available. Tools that are 
not necessary are removed from the interface.

To select a workspace, select the desired User and Project in the File Open dialog.

! Exercise: Select a Workspace

1 Launch MicroStation.

2 At the lower right of the File Open dialog, change the User from untitled 
to examples.

3 Change the Project to General.

4 Click on the file named MicroStation_Essentials_V8i.dgn.

5 Click Open.

You see the MicroStation application window, containing a visual !index" 
of this design file.

MicroStation/J and older versions of MicroStation

Older DWG versions

Thumbnail File Association



Jul-10 7 Welcome to MicroStation
Copyright © 2010 Bentley Systems, Incorporated

The Interface

The Interface

MicroStation!s menus

The main menu bar is located along the top of the MicroStation application 
window. It one of the main sources of commands for controlling MicroStation#s 
operation. 

As you select each menu, a list of menu items appears. Each menu item initiates 
an operation directly, or opens a dialog where you can further define the desired 
operation.

Tool settings 

 Tasks dialog

Main menu bar

View Control toolbox
Main toolbox

AccuDraw window

Attributes toolbox Primary Tools toolbox

View Groups dialog

Status bar
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The Interface

If you are looking for a specific tool to use, select Tools from the main menu bar. 
The resulting menu shows most tools available in MicroStation.

If you need to adjust design file settings, select Settings from the main menu bar 
and then look for, and select, Design File. In this course, this is described as !select 
Settings > Design File!.

The status bar

The status bar is an important part of the MicroStation user interface since it 
provides a view into MicroStation#s operation. MicroStation continually displays 
information about its operation in the status bar. Messages include the following 
the current tool in use and the next step in its use, information about the previous 
action, the status of certain features.

Click on different tools in the Main toolbox and the Tasks dialog and watch as the 
messages at the left of the status bar change. The name of the tool is displayed 
followed by a prompt that instructs you how to start using the tool.

Moving to the right in the status bar, you will find the Message Center.

Informational message

Click on the message, or in the blank area if there is no message, to open the 
Message Center dialog. It lets you review informational and other types of 
messages. In certain cases, an icon indicating the message type displays. 

Main toolbox

The Main toolbox is used to invoke selection, manipulation, modification, and 
measuring tools.

When you press and hold the mouse#s left button, the data button, on a tool in 
the Main toolbox, you see a menu that gives you access to all the tools in that 
toolbox. 
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The Interface

You can open an individual toolbox by doing this and selecting Open %name# as 
ToolBox from the pop-up menu. You can then place, or dock, the toolbox in a 
convenient location on the screen. The Element Selection and Delete Element 
tools do not have an associated toolbox.

You can customize MicroStation toolboxes once they are open. Right click on a 
tool in the box to display a list of the tools available in the toolbox. If you click one 
that was unchecked, it will appear in the toolbox.

Tasks

A task is simply a logical grouping of tools organized by use. Tasks can contain 
overlapping sets of tools. For example, a Drawing task and Drawing Composition 
task can both contain the same text placement tools. 

Tools found in the Tasks dialog on the left side of the application window are used 
to put elements into designs. MicroStation provides default task lists for Drawing 
and Drawing Composition. Click Tasks at the top of the Tasks dialog to see the 
available tasks. When you select a task from the list, the tasks and tool icons 
underneath the Main toolbox change.

The most often used tools

The following list separates commonly used MicroStation tools into four basic 
categories used in 2D drafting.

Creation tools (from the Tasks dialog)

$ Place SmartLine 
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The Interface

$ Place Circle

$ Place Arc

$ Place Block 

$ Place Cell 

$ Place Text

$ Place Dimension

$ Hatch/Pattern Area

Manipulation tools (from the Main toolbox)

$ Copy/Move

$ Scale

$ Rotate

$ Mirror

$ Array

$ Align

$ Copy Parallel (offset)

$ Stretch

$ Move to Contact

Modification tools (from the Main toolbox)

$ Modify

$ Extend Element(s) to Intersection

$ Trim Element

$ Add/Delete Vertex

Miscellaneous tools

$ Element Selection/Fence for grouping elements (from the Main toolbox)

$ Match/Change Element Attributes (from the Main toolbox)

$ Measure (from the Main toolbox or the Tasks dialog)

$ Delete (from the Main toolbox)

$ Print (from the File menu)
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The Interface

Keyboard navigation

Tools can be invoked using the mouse and clicking on the tool, or by using 
keyboard navigation as tools are mapped to the keyboard. 

In this system, the top level is called !home". Look for the home icon in the right 
side of the status bar. If it is not there, press the Esc key on the keyboard. Then, 
from !home", press the keyboard key that corresponds to the tool you want to 
use. The following image shows the tools to which the number keys are mapped.

When accessing tools in the Main toolbox, you use a combination of keys. 
Pressing 3 will open a pop-up menu listing the Manipulate tools. Press 3 again to 
activate the tool that is in the third position, Scale. Press 7 for the Modify tools, 
then the number of the tool you want to use.

! Exercise: Access a tool using keyboard navigation

1 Continuing in MicroStation_Essentials_V8i.dgn, look at the right side of 
the status bar for the home icon.

2 If it is not active, press the Esc key on the keyboard.

3 Press 3.

This key is mapped to the Manipulate tools.
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The Interface

4 Take note of the menu that pops up at the pointer#s location.

It contains all of the tools used for manipulation. You can select a tool 
from this menu or by clicking the tool that is in the third position in the 
Main toolbox and holding the mouse button down.

5 Press 3 again.

Note the tool settings window that floats in the view. It has changed and 
now shows the settings available for the Scale tool.

The tool settings window

Most tools have options to control their operation. These appear in the tool 
settings window. This window is open by default upon start-up. If you close the 
tool settings window, new tool settings will automatically appear when you select 
the next tool.

Hint: Check the tool settings window and the status bar to see which tool is active.

! Exercise: Navigate tasks

1 Continuing in MicroStation_Essentials_V8i.dgn, in the Tasks dialog, click 
the arrow next to Tasks at the top of the Tasks dialog to open the task list.

2 Select the Drawing Composition task.

The available tasks in the dialog change.

3 Click on the Drawing task tab. 

4 With focus at home, press W then 1 to invoke the Place Block tool.

You see in the tool settings and the status bar that the tool is active.

5 Reopen the task list.

6 Click on the + preceding Annotate in the list.

7 Click on Measure.
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The Interface

Now only the tools that belong to the Measure task occupy the Tasks 
dialog. This way only a single key press is needed. Just press the letter that 
corresponds to the tool you want to use.

8 Press Q.

As you see in the tool settings and the status bar, the Measure Distance 
tool is active.

9 Reopen the task list and select the Drawing task so those tools occupy the 
Tasks dialog.

View windows

In MicroStation, the space in which you draw is a view window. You can open 
more than one view window to aid in the design process. View windows are 
resizable, moveable, and collapsible. You can open as many as eight views at any 
time. The reason for eight view windows is so you can view more than one 
portion of a design at one time. 

View controls for each view window

To control the content of a view window, each one has its own set of view 
controls. View controls let you change the contents of one view without affecting 
the contents of any other view. The view control toolbox is located at the top left 
of each open view window.

Models

A model is a separate working space within a design file. 

MicroStation design files can contain multiple models. They are equivalent to 
worksheets in Excel. Worksheets are independent numerical spaces, and models 
are independent graphical spaces. Models contain separate geometry within a 
design file.
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The Interface

! Exercise: Open the model for the next exercise

1 Continuing in MicroStation_Essentials_V8i.dgn, click the arrow next to the 
Models tool in the Primary tools toolbox.

A pop-up dialog opens.

2 Scroll to, and then double click on, the model named Welcome to 
MicroStation.

You see elements representing the Earth.

Note: You can also open models in this file by right clicking the frame around each 
image and clicking Follow Link on the pop-up menu. Select 
!Essential_MicroStation_V8i, Model Name" to open the model. Select 
!ustnkeyin:help topic" to go to a linked topic in the online Help file.

! Exercise: Open and close views

1 Continuing in the Welcome model, click Window on the main menu bar.

2 Hold the pointer over the Views item.

3 Move the pointer to the right and select 2 from the sub-menu (Window > 
Views > 2).

This opens a new view window named View 2.

You can also open view windows using the numbered buttons in the View 
Groups dialog, which is at the lower left of the application window.

4 Click the 8 button in the View Groups dialog.

This opens View 8.

5 Click the 2 and 8 buttons to close the views.
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The Interface

Closing all the view windows in a file is not the same as closing the file. You have 
closed all of the design windows, but the file is still open. The title bar at the top 
of the MicroStation application window displays the name of the open file. Each 
view window#s title bar displays the name of the model you are in.

! Exercise: Use the view controls

1 From the top of View 1, select Zoom In.

The shape of the zoom rectangle is proportional to the view window from 
which the tool was selected.

2 Move the zoom rectangle to center on the Southern tip of South America 
and enter a data point.

3 Change the Zoom Ratio by entering 3.0 in the Zoom Ratio field in the tool 
settings.

Now you will zoom further in or out each time. You can change this ratio 
any time you use the Zoom tools.

4 Zoom in again by entering another data point at the Southern tip of South 
America.
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The Interface

5 Keep zooming in on the dot just visible off the tip of South America until 
you can see what it is.

6 Press the right mouse button to end the Zoom In command.

7 Click OK in the First Reset dialog.

During your first session, the first time you press the right mouse button, 
the First Reset dialog opens. This dialog is used to specify your preferred 
technique for opening a menu called the Reset pop-up menu. Because a 
right mouse click is frequently used, the default selection is 
recommended.

8 Click the 2 button in the View Groups dialog to open the view again.

You can use view controls from one view in another view.

9 Select Fit View from View 2#s view controls.

Now you can see all the elements in the file. 

10 Enter a data point in View 1.

You see all the elements in the view again.

11 Click the 2 button in the View Groups dialog to close the view.

12 Save Settings from the File menu on the main menu bar.

In this course, this type of selection is shown as !select File > Save 
Settings!.

You must explicitly save the arrangement of views on the screen and the portion 
of the design they display. To do this, select Save Settings from the File menu on 
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Working with Tools

the main menu bar, or press Ctrl + F. When you make changes to many settings 
that you want to permanently store, you must save them this way.

Working with Tools

Working with most MicroStation tools consists of the following steps:

1. Select a tool.

2. Adjust the tool settings.

3. Follow the status bar prompts and use the tool.

Starting and stopping tools

The mouse is the primary input device for MicroStation#s graphic user interface.

Data points to confirm

When working with MicroStation#s tools, a left mouse button, or data button, 
click is referred to as entering a data point. The data button is used to select tools 
and menu items. It is also used to enter points, to place or manipulate elements in 
the design, and to confirm input. Consider this the Yes button. !Yes, I want to 
select this tool" or !Yes, I want to enter a point here". 

Reset functions

When working with MicroStation#s tools, a right mouse click is called a reset. You 
use a reset to back up a step during an operation or to end an operation. You can 
consider this the !No" button.

The reset button is used to perform the following functions:

$ It returns you to the previous operational step

$ It resumes the last drawing or editing operation after using a view control

$ It rejects the currently selected element and cycles between eligible elements 
within the location tolerance of the pointer
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The Element Selection tool

Element Selection is a tool for selecting objects in a design file. MicroStation 
defaults to the Element Selection tool whenever no other tool has been chosen. It 
is first in the Main toolbox.

Element Selection is a very versatile tool. Not only can you use it to select 
elements, you can also use it to modify and group elements. 

! Exercise: Get information about elements

1 Continuing in the Welcome model, click the Element Selection tool in the 
Main toolbox (or, with the focus at home, press 1 on the keyboard).

2 Set the following tool settings:

Method: Individual

Mode: New

3 Move the pointer over elements in the design.

The highlighting turns off as you move the pointer away from an element. 
As you move over elements, they highlight. If you enter a data point when 
an element is highlighted, it will be selected. 

The pop-up information that displays will help you to identify the type of 
element.

AccuSnap

The pop-up information is a feature of AccuSnap.When this feature is on, and the 
pointer is near an element, AccuSnap displays information about the element. 

AccuSnap#s main function is to help you select precise locations in a design, such 
as the end of a line or the center of a circle. This operation is called snapping.

With AccuSnap all you do is move the pointer close enough to the point to which 
you wish to snap. AccuSnap moves to the snap point and stays there until you 
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move away. A successful snap using AccuSnap places a bold, yellow X on the snap 
point. The next data point you enter will be placed at precisely that spot.

AccuSnap snapped to the center of the circle

In the next exercises, you will use tools and the mouse to experiment with the 
way the African and South American continents may have looked during the 
Jurassic period.

! Exercise: The reset button!s first function, confirming input

1 Continuing in the Welcome model, move the pointer until it touches a 
portion of the African continent, press the data point button, and continue 
to hold it down.

MicroStation responds by displaying handles around the continent.

2 While holding the data point button down, drag the continent over until it 
touches South America.

You see that it must be rotated to fit correctly. To do this, you#ll need to 
choose a drawing tool.

3 In the Main tool frame, click the Copy tool. press until the menu opens, 
and then select Rotate.
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Or, press 3 + 4 on the keyboard.

4 In the tool settings, click the downward arrow next to Method and select 2 
Points.

5 Make sure the Copies check box is not checked.

You want to rotate the original element, not a copy.

6 Returning to the map, move the pointer between the South American east 
coast and the newly relocated Africa. Enter a data point.

This is the pivot point of rotation. MicroStation responds by putting Africa 
into a dynamic rotation mode. As you move the pointer, the continent 
spins to follow it.

7 Spin Africa around until it fits against South America. 

8 Enter a data point to lock the spun continent into place.

The data point confirms that this location in which you want to place the 
element.

If you move the pointer, you see that MicroStation keeps Africa in its spin 
mode so you can still change the rotation.

9 Press the Reset button on the mouse.

Even though the element no longer spins, the tool settings still indicate 
that the Rotate tool is active. Reset does not cancel a tool; it resets it to 
the previous operational step.

In MicroStation, once a tool has been selected it is active until another 
tool is selected or you reset out of it.

10 Reset again.
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You return to the Element Selection tool.

11 Click Clear in the tool settings to release the continent.

! Exercise: The reset button!s second and third functions

1 Note the direction indicator at the bottom of the design.

The North marker must be rotated.

2 Select Rotate from the Main toolbox.

3 In the Rotate tool settings, set the Method to Active Angle.

4 In the field below that, replace the zeros with 45 and press Enter.

You are ready to rotate, but it will be easier to see if you are closer.

5 Select Zoom In from the view controls and zoom in on the direction 
indicator.

6 Reset.

You return to the Rotate tool. Returning to the original drawing tool after 
using a view control is the second reset function. When you select and use 
a view control tool, just remember to click the reset button after you finish 
adjusting the view. 

7 Place the pointer in the center of the direction indicator.

One of the indicators highlights. It was placed in the file last. However, you 
don#t want this one.

8 Reset until the N indicator highlights.
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9 Enter a data point.

MicroStation cycles through the elements inside of the locate tolerance. 
The locate tolerance is how close the pointer must be to an element in 
order to recognize it. No matter how many elements are within the locate 
tolerance, MicroStation will cycle through them all until you select one or 
until you stop the command. This is the reset button#s third function.

Tips and Tricks

$ To adjust width of Message Center in the status bar, just click bar to the left of 
the icon (or the area if no icon is displayed) and drag.

$ The tool settings automatically hide when the pointer gets too close. To make 
them hide sooner, right click the PopSet tool, which is the last one in the 
Primary Tools toolbox, and select Properties. Then, set the Hide Border option 
to a higher number. If you don#t want the tool settings to hide at all, set it to 0. 
Now click the PopSet icon so it turns green and does not have the slash mark 
through it to turn it on.

$ If tools are displayed in a toolbox and you don#t use them, just right click in the 
toolbox and uncheck the tool name so it will no longer display.

$ If a dialog gets stuck in the corner of a view window, or under the main menu 
bar, simply hold down the Shift key, grab the dialog as close to the one edge as 
possible, and drag it away.
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Module Review

Now that you have completed this module, let#s measure what you have learned.

Questions

1 How do you open files using a Workspace?

2 Identify four elements of MicroStation#s interface.

3 Where must focus be to use task navigation and keyboard mapping?

4 True or False: View controls can only be applied to the view from which 
the tool was chosen.
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Module Overview

This module presents frequently used element creation tools, and provides 
instructions for their use in adding elements to your designs.

Module Prerequisites

$ Knowledge of MicroStation#s interface

$ Some knowledge about MicroStation design elements

$ Knowledge about viewing in MicroStation

$ Knowledge about AccuDraw

$ Knowledge about element attributes

Module Objectives

After completing this module, you will be able to:

$ Add elements to designs

$ Determine which tool is best for a particular task

$ Apply knowledge about familiar tools to new tools

Introductory Knowledge

Before you begin this module, let's define what you already know.
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Questions

1 What is snapping?

2 Working with most MicroStation tools consists of a series of steps. What 
are they?

Answers

1 Snapping let you select specific points, such as an end point, mid point, 
center point or intersection with precision.

2 Select a tool.

Adjust the tool settings.

Follow the status bar prompts and use the tool.

Element Attributes

When placing new elements in a design file, they are assigned specific attributes 
that control their appearance and display properties. These attributes are 
typically set prior to placing the element in the design. They can also be changed 
later. 

Common element attributes are Level, Color, Line Style, Weight, Transparency and 
Display Priority. All of these are set in the Attributes toolbox.

Active color

The active color specifies the color with which new elements will be placed.
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When you select the color tool in the Attributes toolbox you see a dialog that has 
three tabs; Indexed, True Color and Color Book.

$ The first tab is the Indexed Color tab. It lets you select a color from a table of 
256 colors. Each color in the table can be modified, or you can change the 
available colors by attaching a different color table to the design file. These 
colors are not named. They are identified by number.

$ The second tab lets you select a color based upon true color values.

$ The third tab is the Color Book tab. Color books are used to contain a 
collection of named, true (RGB) colors. Naming and categorizing the colors 
allows you to select colors by name rather than by number triplets. When a 
color from a book is assigned to an element, the book and color name are 
stored in the element and can be easily reviewed.

$ A fourth tab is available when using a tool that creates a closed element 
because they can be filled with color. This tab becomes usable when the Fill 
Color option is set in a tool#s tool settings.

Identifying an existing element!s color

There are several ways to do this, just as there are different ways of obtaining 
information about elements.



Element Creation 28 Jul-10
Copyright © 2010 Bentley Systems, Incorporated

Element Attributes

! Exercise: Methods to identify element color

1 Continuing in MicroStation_Essentials_V8i.dgn, click the Models tool in 
the Primary tools toolbox and double click on the Element Creation, 
description, Essentials geometry, model to open it.

Model names and descriptions

Note: You can click the Name column#s header to sort the models by name. 
Just remember to check for the correct description.

2 Select the Element Selection tool.

3 Click on the dashed (yellow) boundary around the geography to select it.

The boundary highlights

4 Click the arrow at the bottom right of the Element Selection tool settings 
to expand them.

5 Click the color tab.

The color that is highlighted at the top of the tab is the color of the 
selected element. If multiple elements are selected, all their colors are 
highlighted at the top.

6 Click the Element Information tool in the Primary Tools toolbox.

7 The word <Selection> is highlighted.
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Since there is only one element selected, you see its properties in the 
General section. The element color is on the Color line. If multiple 
elements are selected, click the individual entries under <Selection> to see 
information about that specific element. The element will highlight in the 
view when you click the entry.

8 Close the Element Information dialog.

9 In the Element Selection tool settings, click Clear to release the boundary.

Active line style

The active line style specifies the line style with which new elements will be 
placed.

MicroStation has two classifications of line styles. The eight standard line styles 
are numbered 0 - 7. There are also custom, user defined, line styles.

$ The standard line styles range from solid to dot-dash combinations. These line 
styles are cosmetic, and are defined in screen units. They do not change size 
when you Zoom In or Zoom Out, so no scale is associated with them.

$ Custom line styles are defined in design units. These line styles are physical, 
and are scalable. They become larger or smaller when you Zoom In or Zoom 
Out. 

Note: There is also support for DWG based line styles, or Linetypes.

Active line weight

The active line weight specifies the line weight with which new elements will be 
placed.

The active line weight is a value between 0 - 31 that is assigned to an element to 
define its thickness. MicroStation#s line weights are defined in screen units, and 
remain static as the zoom factor changes.
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Active element transparency

Transparency is also an element attribute that can be set for elements in the 
Attributes toolbox, just like color, style, or weight.

Set transparency for elements from 0, fully visible, to 100, not visible. The display 
of transparency in a view is controlled in the View Attributes dialog. 

View Attributes

Use View Attributes to change the way you view a design by selecting the types of 
elements that are displayed or how some elements appear. To open the View 
Attributes dialog, either select Settings > View Attributes, click the first tool in the 
view toolbox, or press Ctrl + B. 

Hint: Remember, press Ctrl + B for better viewing. When you do this, the dialog will 
open with the view number set to the view window that has the focus.

Active element display priority

Another element attribute that can be set in the Attributes toolbox is display 
priority.

Display priority is a pre-set value, between -500 and 500, that determines how an 
element is displayed relative to other elements. 

The elements with the highest values are placed in front while those with lower 
priorities are placed in the back. Element priority is only available in 2D models. 
Priority is for 2D, since priority corresponds to the Z value in a 3D model.

Filled elements

A filled element is an element that has color within its boundaries, as opposed to 
being displayed as just an outline. 
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The Fill attribute applies only to closed elements such as circles, ellipses, and 
shapes. By default, a closed element has lines that define the area occupied by 
the element and the area inside the outline is transparent. A closed element is 
filled when the area within the outline is a solid color. 

Unfilled and Filled elements

Creating fill

The element#s fill color is determined by the Fill Color set in the tool settings at 
time of an element#s placement.

The Fill Type option determines the kind of fill.

$ When an element#s Fill Type is Opaque, you see a solid shape. In this case, the 
lines defining the element are not discernible since the fill has the same color. 

$ When an element#s Fill Type is Outlined you can select a fill color that is 
different from the outline color.

Toggle fill display, just like transparency, in the View Attributes dialog. 

! Exercise: Toggle fill display

1 Continuing in the Element Creation model, press Ctrl + B.

2 In the View Attributes dialog, click the Fill icon.

The shading inside the parks and waterways disappears.

3 Close the View Attributes dialog.

Note: You must select File > Save Settings before leaving a file to preserve the status 
of fill display.
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Level

You need to place the correct types of elements on the correct level, as 
determined by your organization#s standards. For example, in mapping, levels 
would be named to describe common features such as boundaries or lot lines. 
Elements that represent these features would then be placed on the respective 
level.

The active level is the level on which new elements will be placed. You can change 
the active level in the Attributes toolbox and in dialogs for working with levels.

The display of elements residing on particular levels can be turned on and off so 
you can see only the information you want to see. Turning levels on or off only 
changes the display status of the elements that reside on the levels.

Note: You must select File > Save Settings before leaving a file to retain the active 
level.

! Exercise: Set the active level and toggle level display

1 Continuing in the Element Creation model, click the Level Display tool in 
the Primary Tools toolbox.

Like the View Attributes dialog, level display is per view. The view to which 
any changes will be applied is in the dialog#s title bar.

The active, or current, level is has a different background. Any new 
element you place will be placed on the active level.

2 Change the Active Level by double clicking another level. 

You see the level name change up in the Attributes toolbox.

3 Click the Name column#s heading to sort the levels by name.

4 Click the level named Boundary.

Display of elements on the level turns off. Only the active level cannot be 
turned off. 
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5 Click the name again to turn display of elements on the level back on.

Hint: You can make a level whose elements you want to see the active level and then 
right click in the list of levels and select All Off so you only see the desired 
elements. Use the Invert command to turn undisplayed levels on and displayed 
levels off.

In the Level Display dialog, click the column headings to sort the levels by name. 
The used column contains a dot if there are elements in it. Click that column to 
sort the levels by use.

Moving elements between levels

You may find that you don#t always create elements on the right level, so you may 
spend time moving elements between levels. Just as you might change an 
element#s color or weight, you can also change its assigned level.

! Exercise: Move elements to another level

1 Continuing in the Element Creation model, move the pointer over the 
North Arrow at the bottom of the view.

The pop-up information indicates that it is on the level named Title.

2 Select Element Selection, with the following tool settings:

Method: Individual

Mode: New

3 Click on the North arrow.

4 In the Attributes toolbox, select Direction from the list of levels to make it 
the active level.

5 In the Element Selection tool settings, click Clear to release the elements.

6 Move the pointer over the North Arrow and note the level.

Hint: You can also use the Level tab in the Element Selection tool settings to select 
elements on a level and then make the level to which you want to move them 
active in the Attributes toolbox.
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ByLevel symbology

Rather than placing design elements with the active element attributes, you can 
place them with symbology settings inherited from the level upon which they are 
placed. This is called ByLevel symbology. 

When elements are placed with the ByLevel attributes and the level symbology 
definitions are changed, the elements reflect the changes. These symbology 
settings are managed by an administrator in the Level Manager dialog. 

Placing elements in the design file with ByLevel symbology requires the active 
color, weight and style to be set to ByLevel in the Attributes toolbox. To set the 
active color, weight or style to ByLevel, select the ByLevel option when you click 
the attribute#s tool.

ByLevel options for color and weight

Creating Elements

Most of the tools in the Tasks dialog add new elements to a model. Although 
elements may vary, the placement tools generally require the usual series of 
steps.

1. Select a tool.

2. Adjust the tool settings.

3. Follow the status bar prompts and use the tool.
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Linear Tasks

These tools are used to place linear elements. Open the Linear toolbox from the 
Tasks dialog or by pressing Q when focus is at home.

The Place SmartLine tool

The most versatile of the linear tools is the Place SmartLine tool. Found in the 
Linear tasks, use this tool to place a chain of connected line and arc segments as 
individual elements or as a single line string, shape, circle, complex chain, or 
complex shape element. 

Place SmartLine lets you create six different element types.

Line, Line String, Shape, Arc, Complex chain, Complex shape 

! Exercise: Use Place SmartLine to extend a trail

1 Continuing in the Element Creation model, set the following in the 
Attributes toolbox:

Level: Trail-Paved

Note: Click the first letter of the level name on the keyboard to skip to those 
levels.

Color, style, and weight are set to ByLevel, and they change accordingly.

2 In the Level display dialog, right click in the list of levels and select All Off 
to turn all levels off.

3 Turn on the following levels:

Arterials

river_lake_canal
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Hint: You can click the Name column heading to sort the levels by name. You 
can also drag the column heading to resize the columns.

4 Zoom In on the area indicated.

5 Select Place SmartLine with the following tool settings:

Segment Type: Lines

Vertex Type: Sharp

Join Elements: Disabled (unchecked)

When Join Elements is disabled, an independent line segment is formed 
every time you enter a data point. 

6 Enter data points, following the roadway, connecting the trail, as shown.
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If you move the pointer over your work, the pop-up information shows 
you that the resulting elements are lines.

7 Select Edit > Undo Place SmartLine.

8 In the Place SmartLine tool settings, enable the Join Elements check box.

9 Reconnect the trail.

10 Move the pointer over your work.

Note: If you enter a data point and place an incorrect vertex, press Ctrl + Z or select 
Edit > Undo and then resume entering data points.

In the next exercise, you will connect two roadways.

! Exercise: Use Place SmartLine to create a connector road

1 Continuing in the Element Creation model, make the level Arterials the 
active level in the Attributes toolbox.

2 Set the following Place SmartLine tool settings:

Segment Type: Arcs

Vertex Type: Rounded

Join Elements: Enabled

3 Snap to the end of the existing road on the right.
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4 Noting the status bar prompt, move the pointer to the left, and enter a 
data point half way between the two roads.

This is the arc#s center.

5 Sweep the arc around counterclockwise, and snap to the road on the left 
to connect.

6 Reset.

Place Stream Line String

Use this tool to trace images when digitizing. You can define many vertices 
without entering many individual data points.

To use it, select the tool, enter a data point to define the origin, and then move 
the pointer. A stream of data points is placed without entering a data point. Reset 
to end the line string.

Canal extended using Place Stream Line String

Construct Minimum Distance Line

Use this tool to construct a line between two elements at their closest points.
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To use it, select the tool, enter a data point to identify the first element and then 
another to identify the second element. Enter a data point to accept.

Construct Line at Active Angle

The active angle is used with tools that require an angle specification, including 
Place Line, Place Active Cell, Place Text, Rotate, and Construct Array. So, if you 
place a line at 90 degrees, any other element that has Active Angle in its tool 
settings will be placed at a 90 degree angle unless you change the Active Angle 
again. 

Use this tool to construct a line, at the Active Angle, that intersects another line 
segment or a shape.

There are two methods. Using from Point, the intersection is defined when the 
element being intersected is selected (first data point). Using To Point, the 
intersection is defined by the second data point.

AA indicates the active angle, 1 is the first data point and 2 is the second
On the left, you see From Point, on the right you see To Point

Place Freehand Sketch

If you open the Linear Elements or Linear Elements Classic toolbox by selecting 
Tools > Toolboxes, you will find this tool. Use it to draw a freehand line.
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To use it, select the tool, enter a data point to define the origin, and then move 
the pointer with the data button pressed. Release the mouse button when you 
are done.

Circles Tasks

Use these tools to place ellipses, including circles and arcs. Open the Circles 
toolbox from the Tasks dialog by pressing E when focus is at home.

The Place Arc tool

The Place Arc tool is used to place a circular arc in either a clockwise or counter-
clockwise direction.

There are three methods by which to place arcs.

$ Using Start, Center the arc is constructed by identifying its start point, 
identifying a center point, and then the sweep angle and direction.

$ Using Center, Start the arc is constructed by identifying the point you want at 
the center, then its start point, and then the sweep angle and direction.

$ Using Start, Mid, End the arc is constructed by entering three data points 
defining its start, a middle, and end.

$ Using Start, End, Mid the arc is constructed by entering three data points 
defining its start, end, and the middle.

! Exercise: Place arcs to complete the baseball field

1 Continuing in the Element Creation model, open View 8 and make the 
level Sports the active level.

2 Select Place Arc, with the following tool settings:

Method: Start, End, Mid

The status bar prompts you to identify the start of the arc.
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3 Snap to the dugout on the left and enter a data point.

4 Snap to the other dugout and enter a data point.

You have now identified the start and end of the arc. Guide lines appear.

5 Move the pointer to a location between the start and end.

When the guideline x is in the area where home place should be, enter a 
data point.
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6 Reset.

The Place Circle tool

Circles can be placed using different methods. Since a circle is a closed object, it 
can be filled with a solid color or a gradient of colors.

There are three methods by which to place circles. 

$ Position them by defining their Center and then create the circle dynamically. 
When you do this, you can see the diameter change dynamically in the tool 
settings# Diameter field.

$ Position them by Edge, defining three points on the circumference. After you 
enter the second data point, a guide line appears and you can see the size 
dynamically. You can also see the diameter change dynamically in the tool 
settings# Diameter field.

$ Using the Diameter Method, you use two data points to establish the 
diameter dynamically.

You can place a circle by diameter another way. Enable the Diameter check box 
and type the diameter into the input field. Use the Center Method and enter one 
data point to place the circle, o, use the Edge Method and two data points.

! Exercise: Use Place Circle to create bases

1 Continuing in the Element Creation model, select Place Circle, with the 
following tool settings:

Method: Center

Diameter: Enabled and type 8 in the input field

2 Snap to each corner of the field and enter a data point.

3 When you are done, close View 8.

Polygons Tasks

These tools let you create a variety of planar shapes. 
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Open the Polygons toolbox from the Tasks dialog or by pressing W when focus is 
at home.

Place Block and Place Regular Polygon are the most useful of these tools as the 
Place SmartLine tool can produce the same geometry as Place Shape and Place 
Orthogonal Shape. Since polygons are closed elements, they can be filled with 
color.

! Exercise: Turn on levels and rotate the view for easier element placement

1 Continuing in the Element Creation model, in the Level Display dialog, turn 
on all levels.

2 Turn Fill back on in the Attributes dialog.

3 Fit View and then select File > Save Settings from the main menu bar so 
the view will be the same the next time you enter the model.

4 Zoom In to the area indicated.

5 Select Rotate View from the view controls, with the following tool setting:

Method: 2 Points

6 AccuSnap to the upper right corner of the golf club and enter a data point.
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7 AccuSnap to the lower right corner and enter a data point.

The view rotates so that it is aligned with the golf club.

The Place Block tool

Place Block places a square or rectangular shape. 

Using the Orthogonal method, the block is orthogonal to the view in which the 
first data point is entered. Using the Rotated method, orientation is defined with a 
data point.

! Exercise: Use Place Block to enlarge the golf club

1 Continuing in the Element Creation model, with the pointer over the golf 
club, press and hold the Alt key on the keyboard, and then left click to set 
the active attributes to those of the element.

Note the change in the Attributes toolbox.

2 Select Place Block from the Tasks dialog.

You see that the attributes in the tool settings are set correctly from the 
match operation.

3 Set the following tool setting:

Method: Orthogonal

4 Following the status bar prompt, AccuSnap to the upper left corner of the 
golf club and enter a data point. 

5 Move the pointer upward and note the AccuDraw window at the bottom 
of the application window.

As the pointer moves, the values in the X and Y fields changes.
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6 Type 300 into the Y field.

7 Move the pointer to the right, type 200 in the AccuDraw window, and 
enter a data point.

8 Accept with a data point.

Place Regular Polygon

This tool is used to place a regular polygon, a shape with equal length sides and 
equal angles at each vertex. For example, a square is a four-sided regular polygon.

! Exercise: Use Place Regular Polygon to add a school

1 Continuing in the Element Creation model, select Place Regular Polygon 
from the Tasks dialog.

2 Set the following tool settings:

Method: Inscribed

Edges: 6

Radius: 0

Area: Solid

Fill Type: Opaque

Fill Color: 127

3 Set the following in the Attributes toolbox:
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Level: Sch prop_-Sep

Color: 127

Style and Weight remain the same

4 Following the status bar prompt, enter a data point to place the center 
point of the regular polygon, as indicated.

As you move the pointer, the polygon spins.

5 Rotate the polygon so that an edge is parallel with the street and size it so 
it fits in the area.

6 Enter a data point to complete.

7 Select Rotate View, with the following tool setting:

Method: Unrotated

Hint: View Previous can also be used to return to the view to its original 
orientation.

Complex Chains, Shapes and Regions

Some groupings in MicroStation, such as a set of selected elements, are 
temporary. Other groupings are more persistent. 
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The Groups toolbox contains tools that are used to create and manipulate more 
permanent element groups.

Groups tools from the Main toolbox and the Groups toolbox

The Create Complex Shape tool

The Create Complex Shape tool is similar to Create Complex Chain, except the 
resulting element is closed rather than open. The same tool options are available 
for both tools, but Create Complex Shape also has options for controlling the fill 
attributes of the closed shape. 

In the next exercise, you will use the boundaries of existing areas to create a 
complex shape.

! Exercise: Create a park using a complex shape

1 Continuing in the Element Creation model, Fit View and then Zoom In to 
the area indicated.

2 Set the following in the Attributes toolbox:

Level: park - outside

Color, Style and Weight: ByLevel

3 Select Create Complex Shape, with the following tool settings:

Method: Manual
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Area: Solid

Fill Type: Opaque

4 Following the status bar prompt, click on the roadway as indicated, and 
accept with a data point.

5 Continue entering data points to add the next elements, working around 
the area enclosed by the roads.

6 Enter a data point to complete the complex shape.

You have created the park, but there is another way to do this.

7 Select Edit > Undo.

8 Change the following tool setting:

Method: Automatic

Max gap: 0
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The Max Gap option sets the largest distance allowed between 
consecutive elements, if Method is Automatic. If it is set to zero, only 
elements that connect can be added.

9 Enter a data point on the roadway where you began previously, and then 
enter a data point inside the area.

Note the status bar. A road segment highlights, but it is the wrong one.

10 Reset.

11 Enter data points inside the area enclosed by the roads until the complex 
shape is formed. Reset every time you encounter a fork and an undesired 
element is highlighted.

The Complex Chain tool

Similar to the Create Complex Shape tool, use the Create Complex Chain tool to 
combine existing elements into a continuous open ended element.

The Manual method requires you to identify each element you want to add with a 
data point. The Automatic method uses the first element selected as a starting 
point and then searches for subsequent elements, converting them into a 
complex chain.

The Max Gap field defines the maximum distance that can exist between 
elements so they are found when the method is set to Automatic.

If enabled, Simplify Geometry creates a primitive line string rather than a complex 
chain.

The Create Region tool

Create Region creates a complex shape from two or more existing elements. It 
generates a shape by comparing the relationship between the elements. You can 
create regions from the difference between elements, the intersection of 
elements, the area that is the union of elements, or by identifying an enclosed 
area, which is called by flood.
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When Keep Original is enabled in the tool settings, you create a new shape and 
leave the original elements in place. When disabled, the elements used as 
components in creating the new shape are deleted.

In the next exercise the redline modifications require you to create a new park.

! Exercise: Create a region to extend the park

1 Continuing in the Element Creation model, select Create Region, with the 
following tool settings:

Method: Flood

Fill Type: Opaque

Ignore Interior Shapes: Enabled

2 Enter a data point in the area above the new park.

The shape boundary highlights.

3 Enter another data point to accept the shape.

4 Fit View.

Undo, Redo, and Delete

You can eliminate a design error by returning to the state in which the design 
existed before you made it. The Undo command lets you reverse the last design or 
modification action. 
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MicroStation provides a sequential unlimited undo buffer that lets you recover 
from a graphical mistake, such as drawing a line in the wrong location. There is no 
limit to the number of undo operations you can perform within a design session. 
However, if the file is closed or compressed, the undo buffer is cleared. 

To undo the last design operation, press Ctrl + Z, select Undo from the Edit menu, 
or open the Tools > Standard toolbox and click the Undo tool.

Standard toolbox

One way to address a mistake is to reverse it, another is to delete it. The Delete 
tool lets you remove an element from the file. Click the tool; it has no tool 
settings, and then click the element you want to delete.

Element templates

Another way to apply element attributes is by using an element template.

An element template defines properties of elements. It stores multiple element 
properties. You can set general properties such as level, color, line style, and line 
weight; closed element properties such as area and fill color; and many other 
properties. Once an administrator sets up templates, you can apply them to 
existing elements or use them to create elements.

The first tool in the Attributes toolbox is the Active Element Template tool. 
Selecting an element template will activate the settings stored in the template. 
The tool tip shows you the active template.

When attributes are set this way you have the ability to link the attributes to the 
elements that are placed using them. If you do this the elements# attributes will 
update if the template definition is updated.

! Exercise: Change the active attributes using an element template

1 Continuing in the Element Creation model, take note of the attributes that 
are currently active in the Attributes toolbox.

2 In the Attributes toolbox, click the arrow next to the Active Element 
Template tool.

3 Expand !Example Template Group" by clicking the +.
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The available element templates are listed in a hierarchy.

4 Click on Template A.

The template is set and the active attributes change.

5 Click on Template B.

The attributes change once again.

Working with Cells

Cells are complex elements that group multiple elements permanently. You save 
these groupings to represent symbols that are used often. You can then place 
them into designs without recreating the symbol each time. Cells can be made 
from any element or combination of elements. 

A specific series of steps is required to use cells in a design file. First, you must 
attach the file in which the cells are saved, and then you can place the available 
cells.

! Exercise: Attach a cell library

1 Continuing in the Element Creation model, select Element > Cells from the 
main menu bar.

2 From the Cell Library dialog#s File menu, select Attach File.

You can attach a single file containing cells or you can attach an entire 
folder that contains files that have cells in them. 

3 Navigate to \Projects\Examples\Geospatial\cell, select Geospatial.cel, and 
then click Open.

The cells in the library populate the dialog.
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Placing cells in designs

The cell library is now attached to the design file. You can place any of the cells 
stored in this library in the design using tools in the Cells toolbox. Open it from the 
Tasks dialog or by pressing S when focus is at home.

! Exercise: Placing a cell that represents a boat ramp

1 Continuing in the Element Creation model, Zoom In to the area indicated.

2 In the Cells dialog, click on the cell named BOAT in the list of cells.

Note the preview of the cell.

3 Click the Placement button. 

This makes the selected cell active.

4 Close the Cell Library dialog.

5 Select Place Active Cell from the Tasks dialog.

6 Extend the tool settings by clicking the arrow at the lower right.

7 Set the following tool settings:

Active Angle: (type in) 70

X and Y Scale: 1.0

True Scale: Enabled

Hint: You can use the arrows next to the tool settings Active Angle field to set 
the angle to predefined values.

8 Enter a data point on the left side of the lake to place the cell.
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9 Reset.

Placing cells that already exist in a design

Use Select And Place Cell to identify a cell in the DGN file and place an additional 
instance of that cell.

! Exercise: Place a shop near the boat ramp

1 Continuing in the Element Creation model, select Select And Place Cell 
from the Tasks dialog.

2 Set the following tool settings:

Active Angle: 0

X and Y Scale: 1.0

3 Enter a data point on the cell named SHOP at Market Plaza.

Hint: AccuSnap#s pop-up information shows the name of a cell.

4 Enter a data point above the boat ramp to place a second instance.

5 Reset.

6 Select the new cell using Element Selection.

7 In the Attributes toolbox, change the color to 6 (orange).

8 Click in the view to release the element.
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True Scale

MicroStation uses working units to accommodate different systems of 
measurement. When working units differ between files, the relationships must be 
determined and then cells scaled accordingly. 

When placing a cell that was created in a file that has different working units than 
the active file, you can make the cell scale properly at the time of placement by 
enabling True Scale in the tool settings. True Scale aligns the units in the cell, one 
to one, with the units in the active design.

For example, if a cell was created using feet and inches, but the working units in 
the active file are Metric, the cell will be the wrong size. True Scale reads the units 
in which the cell was created and adjusts the scale based on the active design#s 
working units.

It is a best practice to have True Scale on when placing cells. If there is any 
question, consult your administrator.

Creating cells

When administrators create a cell, they define an origin for the cell. This is the 
location by which the cell is placed. They also set the cell type; graphic, point, or 
menu.

Graphic cells

The color, line style, and line weight of a graphic cell are determined when it is 
created. A graphic cell rotates when a view is rotated. A graphic cell is always 
placed using the color, weight and style with which it was created. You can also 
snap to any element in the cell once it has been placed.

However, if cells are created using ByLevel attributes and then placed into a 
design that has the same level name but that level has different attributes 
assigned to it, the cell will reflect those attributes. The cell will not look the same 
as it was originally created.
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Point cells

An active point is used as a reference, or monument, point in a design. It can 
consist of a cell from the attached cell library, a text character, a symbol, or a line 
with no length.

Point cells take on the attributes that are active when the cell is placed. If color 6 
is the active color, the cell is placed using color 6, as well as the currently active 
line style, weight, and level. A point cell includes only one point that you can snap 
to, the cell#s origin. Point cells do not rotate when a view is rotated. A point cell 
can be especially useful for adding text that you want to remain stationary in a 
design. To place a point cell, select the Place Active Point tool from the Linear 
tasks. Click the magnifying glass next to the Cell field to open the Cell Library 
dialog. Select a cell and click the Point button. Enter a data point to place the cell.

A DGN file can also be attached as a cell library. Each model in the file that was 
created with the !Can be placed as a cell" check box enabled will be listed in the 
Cell Library dialog.

! Exercise: Create a cell

1 Continuing in the Element Creation model, Fit View.

2 Select Element Selection and select the elements that make up the North 
arrow.

3 Select Define Cell Origin.

4 Enter a data point on the selected elements.

5 In the Cell Library dialog, click the Create button and type the following, 
and then click Create:

Name: North Arrow

The cell is added to the library.

6 Select Define Cell Origin to remove the origin point.

7 Reset and click Clear in the Element Selection tool settings.

8 Fit View.
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9 Select File > Save Settings from the main menu bar so the view will be the 
same the next time you enter the model.

Replacing cells

The Replace Cells tool replaces cells using a designated replacement, or updates 
cells having the same name, using cells from the active cell library.

It places the origin of the new cell at the same location as the old one, 
maintaining the original scale and rotation. 

To update cells from the active cell library, select the tool and set the Method to 
Update in the tool settings. Identify the cell to update and accept it. To replace 
cells individually or globally, select the desired Mode and set the Method to 
Replace in the tool settings. Identify the cell to replace, identify the replacement 
cell, and accept.

Line terminators

The Place Active Line Terminator tool places a cell at the end of the selected 
element, rotating the cell to match the angle of the element. It is good for placing 
arrowheads.

To use it, select the cell, click the Terminate button in the Cell Library dialog, 
select the tool, and then identify the element.

Note: Do not snap to the elements you want to terminate. The tool will find the end 
point.

Shared cells

The first time you place a cell with Use Shared Cells enabled in the Cell Library 
dialog, its definition, the elements comprising the cell, are stored in the DGN file 
one time and if additional instances of the cell are placed the definition is 



Element Creation 58 Jul-10
Copyright © 2010 Bentley Systems, Incorporated

Precise Element Placement

referenced. With an unshared cell, its definition is stored in the DGN file each time 
the cell is placed. 

A cell library does not need to be attached to place more instances of a shared 
cell. A shared cell can have many instances in a DGN file, but has only one 
definition. This keeps the size of the file smaller. When a shared cell instance is 
replaced using the Replace Cells tool, all instances of the cell will be replaced.

Precise Element Placement

All engineering drawing applications include tools to help a user select precise 
coordinate locations in a design, such as the end point of a line or the center of a 
circle. This operation is called snapping.

AccuSnap

As you have been working, you have seen pop-up information that displays. It is a 
feature of AccuSnap. When this feature is on, and the pointer is near an element, 
AccuSnap displays information about the element.

AccuSnap#s main function is to help you select precise locations in a design, such 
as the end of a line or the center of a circle. This operation is called snapping.

With AccuSnap all you need to do is move the pointer close enough to the point 
to which you wish to snap. AccuSnap moves to the snap point and stays there 
until you move the mouse away. A successful snap using AccuSnap displays a bold, 
yellow X on the snap point. The next data point you enter will be placed at 
precisely that spot.

Snap modes

You snap to elements to locate the exact point at which you want to place an 
element, or interact with the element. Snap modes help you get the point you 
want. The most common snap is the Keypoint snap. It snaps to key points on an 
element, like the ends of a line or the center of a circle.
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With the Keypoint snap mode active, snap points are located using 
mathematically derived key points. MicroStation uses a keypoint divisor to divide 
an element into equal parts. For example, a divisor of 2 means that an element is 
divided into two equal parts, creating three key points; the two end points and 
the mid point.

Snap modes can be accessed most easily from the Snap Mode button bar, which 
can be opened by selecting Settings > Snaps > Button Bar or by clicking the snap 
mode icon in the status bar and selecting Button Bar from the pop-up menu.

AccuSnap is enabled and Keypoint is the default snap mode

To set the default snap mode, double click on any available button.

Keypoint is the default snap, but Center is the override

To set a snap mode override for one operation only, single click any available 
button once. The override snap mode overrides the default snap mode for one 
snap operation only. When complete, MicroStation returns to the default snap 
mode.

! Exercise: The keypoint snap

1 Open the Snap Modes model.

Hint: Remember, you can always use the view controls to adjust what you see 
on the screen.

Keypoint lets you snap to element key points like vertices, the center, or 
the end of a line.

2 Select Place SmartLine.

3 Move the pointer over the (blue) dash-dot line string at the upper left of 
the design.

As you approach a keypoint, the tentative hint crosshair appears, along 
with the keypoint snap icon.
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The AccuSnap x will appear when the pointer is on the keypoint.

4 Move the pointer to the upper right end of the line string.

5 When the AccuSnap x appears, enter a data point to snap to the location 
and enter the first vertex.

6 Move the pointer to the intersection of a horizontal and a vertical 
segment.

7 When the AccuSnap x appears, enter a data point to snap to the location 
and enter the next vertex.

8 Move the pointer to another intersection of a horizontal and a vertical 
segment.

9 When the AccuSnap x appears, enter a data point to snap to the location 
and enter the next vertex.

10 Reset.

! Exercise: Make the midpoint snap the override snap

1 Continuing in the Snap Modes model, select Place Block.

2 Click the Active Snap icon in the status bar and select Button Bar from the 
menu.

3 Dock the Button Bar at the bottom of the application window.

4 Click the Mid Point snap once in the Snap Mode button bar to override the 
active keypoint snap mode.

This mode snaps to the midpoint of the segment closest to the pointer.

5 Move the pointer over the second element, the line.

The tentative crosshair appears at the line#s midpoint along with the 
midpoint snap icon. As the pointer approaches the midpoint, the 
AccuSnap x appears

6 Enter a data point to snap to the point and start the block.
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You can see in the Button Bar that the midpoint snap override is no longer 
active and the keypoint snap is the active snap mode again.

7 Click the midpoint snap once.

8 Move the pointer to the next element, the arc.

9 When AccuSnap identifies the midpoint of the arc, enter a data point to 
snap the corner of the block to that point.

10 Reset.

You can see on the Button Bar that the snap mode returns to keypoint.

! Exercise: AccuSnap and the center snap

1 Continuing in the Snap Modes model, set the center snap as the override 
snap.

2 Move the pointer over the next element, the circle.

AccuSnap snaps to the center point of the circle.

3 Enter a data point.

Note: If you were still in keypoint snap mode, AccuSnap would still find the 
center of the circle. The center of a circle is also a keypoint.

4 Set the center snap as the override snap.

Center snap is useful for finding the center point of an arc.

5 Move the pointer to the arc.

The AccuSnap x moves to the center of the arc.

6 Enter a data point.

7 Reset.

! Exercise: AccuSnap and the intersection snap

1 Continuing in the Snap Modes model, select Place Circle, with the 
following tool settings:

Method: Center

Diameter: Disabled

2 Change the active snap mode to intersection.
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Intersection snap calculates the intersection of elements.

3 Move the pointer over the point where the two lines intersect.

The two intersecting lines are highlighted and one is dashed. The dashed 
element is the one to which you will snap.

4 Enter a data point to accept the intersection as the center point of the 
circle.

5 Enter a data point to place a circle.

6 Reset.

Tips and Tricks

$ You can match any color anywhere with the eye dropper tool. Find it on the 
True Color (second) tab of the color picker, opened from the Attributes 
toolbox. Match any color anywhere on your desktop by simply dragging it over 
the item.

$ You can change the color that elements highlight on a per-design file basis. 
Select Settings > Design File and select the Color category in the Design File 
Settings dialog. Set Element Highlight Color or Selection Set Color to whatever 
you want. Drawing Pointer Color affects the color of the Element Selection 
arrow circle.

$ You can also set the Active Angle by selecting Utilities > Key-in, typing ACTIVE 
ANGLE PT2 in the field at the top, and then entering two data points to define 
the angle. Use ACTIVE ANGLE PT3 to set by 3 points.

$ If you want to change regular cells in a DGN file to shared cells, save the file to 
the DWG format. To do this, just select File > Save As and set the Save as type 
to Autodesk(R) DWG Files (*.dwg). Click Save.
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Module Review

Now that you have completed this module, let#s measure what you have learned. 
You can test your skill using the geometry in the Element Creation Challenges, Test 
Your Skill, model.

Questions

1 True or False: An active creation tool can only be used to draw one object. 
To draw two objects you must select the tool again.

2 Name an attribute that closed elements can have, which open ones 
cannot.

3 Why are Place Block and Place Regular Polygon the most useful of the 
Polygons tools?

4 Name three methods you can use to create a region.

5 Name three snap modes.

6 How can you determine the name of a cell that is in a design?
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Module Overview

AccuDraw is more than a precise way to create element geometry. It lets you 
produce complex geometry quickly.

Module Prerequisites

$ Fundamental knowledge of the Microsoft Windows operating system

$ Knowledge of MicroStation#s interface

$ Some knowledge about MicroStation design elements

$ Knowledge about viewing in MicroStation

Module Objectives

After completing this module, you will be able to:

$ Draw with more accuracy and speed

$ Use AccuDraw shortcuts and interface components

$ Use the calculator to increase design accuracy

Introductory Knowledge

Before you begin this module, let's define what you already know.
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Questions

1 List the steps needed to use a MicroStation tool.

2 Name three element creation tools.

3 When do you use the tool settings window?

Answers

1 Select a tool.

Adjust the tool settings.

Follow the status bar prompts and use the tool.

2 Place SmartLine, Place Circle, Place Block.

3 When you need to change the current tool#s operational parameters.

AccuDraw Basics

AccuDraw does not create or manipulate elements, it assists in their creation and 
manipulation. AccuDraw improves quality and speed by reducing keystrokes and 
mouse clicks.

Drawing presents graphic problems using a graphic application, but you are 
traditionally taught to use numeric solutions. AccuDraw is a graphic solution to 
graphic problems.

AccuDraw can infer information from your actions. If the Place Block tool is 
selected, AccuDraw operates in a Rectangular, XY, coordinate system. If Place 
Circle is selected, it switches to a Polar, distance/angle coordinate system. 

Toggle AccuDraw using the AccuDraw icon in the Primary Tools toolbox.
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When enabled, AccuDraw has two components, the AccuDraw window, which is 
docked at the bottom of the application window, and the AccuDraw compass. 
These two interface elements work with each other.

AccuDraw window and the AccuDraw compass in rectangular mode

The AccuDraw window has two modes that can be toggled using the space bar 
when AccuDraw is active and has the focus. Rectangular mode lets you enter X 
and Y distances from AccuDraw#s origin. Polar mode lets you enter the distance 
and angle from the origin. 

The compass consists of three components that are visible in either Rectangular 
or Polar mode.

$ The origin is the center of the compass and is always location 0,0 regardless of 
where the compass is in the design (a relative origin). 

$ The rectangle or circle is referred to as the drawing plane indicator and it 
shows you the drawing plane that AccuDraw is on; Rectangular or Polar.

$ The heavier weight green and red ticks are AccuDraw#s axis markers and are 
completely independent of both the drawing axis and the view axis.

The AccuDraw workflow

If you plan to use AccuDraw, you may need to change your workflow because it 
considers three things and changes behavior accordingly.

First, it considers the active tool. For example, if the active tool is Place Block it 
will remain in Rectangular mode, which is expressed as X and Y distances from its 
origin. If the selected tool is Place Arc, AccuDraw will switch to Polar mode, which 
is expressed as distance and angle.

Second, AccuDraw considers the location of the pointer with respect to its origin. 
As you move the pointer around the compass, AccuDraw updates the X and Y 
values in the AccuDraw window#s key-in fields to reflect the distance the pointer is 
from its origin.
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Finally, AccuDraw considers and interprets keyboard shortcuts. These are single or 
dual character key-ins to drive its behavior. An example is using the space bar to 
toggle between the Rectangular and Polar modes.

When the mouse moves, AccuDraw tracks the pointer's location in relationship to 
the AccuDraw compass. The operational steps for AccuDraw are as follows.

1. Enter a data point to fix the location of the compass.

2. Move the pointer in the direction in which you wish to draw.

3. Without using the pointer to put focus into the AccuDraw window#s key-in 
fields, enter the desired distance value.

4. <Optional> Move in another direction.

5. <Optional> Enter another distance value.

6. Enter a data point to accept.

7. Repeat from step 2 to continue drawing.

You know the direction in which you need to draw by looking at your notes and 
plans. Focus on the direction in which you want to draw, not the X or Y dimension. 
The X and Y dimensions are useful, but when drawing they should not be the 
focus.

The input focus

As you move the pointer, AccuDraw continually updates the field that is currently 
active in the AccuDraw window. It is indicated by the highlighted field title. 
AccuDraw#s input focus lets you enter values wherever the insertion bar is 
highlighted.

If the pointer#s movement away from the previous data point includes a higher X 
value than the Y value, the X field will have the input focus. If the pointer#s 
movement away from the previous data point includes a higher Y value than the X 
value, the Y field will have the input focus.

Move in the X direction and focus is in the X- field
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Move in the Y direction and focus is in the Y- field

Once a field has input focus, the input field becomes auto-overwrite and auto-
enter. You do not have to highlight or click in the fields, or press the Enter key.

AccuDraw indexing

AccuDraw can index to axes, the origin, and the previous distance. The indexing 
feature works like AccuSnap. When you get close to an indexing state, the pointer 
temporarily locks on to that state. For example, when the pointer nears a 90 
degree angle to the origin of the compass it will index to that angle.

! Exercise: Observe AccuDraw indexing

1 Open the Precision Input with AccuDraw, description, Essentials geometry, 
model.

2 Select Place SmartLine from the Tasks dialog, with the following tool 
settings:

Segment Type: Lines

Vertex Type: Sharp

3 Following the status bar prompt, enter a data point to start the first vertex.

Not indexed to the axis
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Indexed to the X-axis
Note Y=0

4 Move the pointer slowly toward the X-axis. 

Once you are within 10 pixels, the line will move to, and stay on, the X-
axis. 

5 Move the pointer toward the Y-axis. 

6 Move the pointer near the AccuDraw origin.

Not indexed to the AccuDraw Origin

Indexed to the AccuDraw Origin. Note X & Y=0
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7 Enter a data point and move perpendicular until you are close to the 
distance of the first segment.

First segment drawn

Second segment shows previous distance with a short T-line. 
Note distances are equal for both segments

Drawing with AccuDraw

Your next task is to draw the following object using AccuDraw and Place 
SmartLine.

You can calculate the missing dimensions from the information given
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You will start at the lower left and move in a counter-clockwise direction.

! Exercise: Draw a shape using AccuDraw

1 Continuing in the Precision Input with AccuDraw model, select Place 
SmartLine, with the following tool setting:

Join Elements: Enabled

2 Following the status bar prompt, enter a data point anywhere to start. 

This is the first vertex of the element and the AccuDraw compass appears 
at the data point location.

3 Move the pointer to the right, lining up with the X-axis.

This is called indexing.

4 Without moving the pointer into the AccuDraw window, type 2000. 

5 Enter a data point to accept the value. 

Note that the compass moves to the last data point.
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6 Move the pointer upward and line up with, or index to, the Y-axis.

7 Type 1500 and accept with a data point.

8 Move the pointer to the left and index to the X-axis.

9 Type 1000 and accept with a data point.
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10 Move the pointer downward and index to the Y-axis.

11 Type 750 and enter a data point to accept.

12 Move the pointer to the left, index to the X-axis, type 1000, and accept 
with a data point.

13 Move the pointer downward, index to the Y-axis, type 750, and accept 
with a data point to close the shape.

Hint: Keep the mouse steady. If you move the mouse around too much, indexing will be lost.

Locking coordinate values

When you enter a value from the keyboard, AccuDraw locks the current input 
field and immediately affects the pointer#s motion because it knows you are 
entering coordinate data.
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After entering a value in the first field, move the pointer until the input focus 
changes to the other field and you can enter the other value. The coordinates you 
have entered establish a point for the placement of the element.

AccuDraw Shortcuts

AccuDraw#s behavior is influenced by the current tool, the location of the pointer, 
and keyboard shortcuts. AccuDraw anticipates your next move. Sometimes, 
however, you will want to direct AccuDraw, so there are a variety of single and 
double character command directives known as the shortcut key-ins. By pressing 
the appropriate key while focus is in the AccuDraw window you can direct 
AccuDraw to perform a specific task.

These shortcuts only work when the AccuDraw window has the focus (is the 
active window). When you select a tool, the focus does not go to the AccuDraw 
window. 

Hint: When you enter a data point to start using the tool, then the focus will shift to 
the AccuDraw window.

Note: Press Esc then the space bar to move the focus to the AccuDraw window.

To open a window showing a list of all AccuDraw shortcuts, press the ? key. This is 
the only shortcut you need to memorize, since it will show you all the rest.

! Exercise: Focus and the ? shortcut

1 Continuing in the Precision Input with AccuDraw model, select Place 
SmartLine.

Note that focus remains at home.

2 Press F11 to shift the focus to AccuDraw.

After entering the X value 
and then moving in Y, you 
will lock the X value. Note 
the letter "X! is depressed

Note the additional index line 
indicating the Y is not yet locked. 
Note the letter "Y! is raised
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3 Press the ? key and expand the AccuDraw Shortcuts window.

4 Return focus to the AccuDraw window by pressing F11.

5 Press G then T, <GT>, to move focus to the tool settings window.

Note: The focus can be moved to the tool settings window by pressing F10.

Often used shortcuts

Space Bar = Change display mode

The space bar toggles between Rectangular and Polar mode.

AccuDraw window in Rectangular, top, and Polar, bottom, modes

X = toggle X lock, Y = toggle Y lock

The <X> or <Y> keys can be selected at any time to lock or unlock the present X or 
Y values when in Rectangular mode. A field is locked when its icon label is 
depressed.

D = toggle Distance lock, A = toggle Angle lock

<D> or <A> can be selected to lock or unlock the Distance or Angle values in Polar 
mode.

Enter = Smart Lock

Smart Lock will index to the closest axis and lock the opposite field value. For 
example, if the X value is indexed, the Y value will be locked at 0. This lets you 
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draw in one direction but snap to objects in the other direction. In Polar mode, if 
Distance is active, the Angle will be locked.

Q = Quit

Press <Q> to quit AccuDraw.

V = View rotation

Press <V> to rotate the compass to align with the view axis. This is especially 
useful when working with rotated views.

O = Set Origin

Pressing <O> moves the compass to the current pointer position or a tentative 
point. This is very helpful when combined with AccuSnap.

Note: You can place the AccuDraw origin at a tentative point. By snapping to a point 
and then pressing <O>, you can place the AccuDraw origin at that point. Do not 
accept the tentative point, just tentative snap and press <O>. When using this 
technique it is important NOT to accept the tentative snap.

RQ = Rotate Quick

<R><Q> temporarily changes the rotation of the compass to a user defined angle. 
Once a data point has been entered, the compass resumes its normal orientation.

I = Intersect Snap

Activates Intersect snap mode.

C = Center Snap

Activates Center snap mode.
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In the following exercise you will place a rotated block at the same angle as an 
existing line.

You will draw the rotated block based on the line

Without using AccuDraw, you would measure the angle, create a construction line 
for the offset distance, and then place the block. AccuDraw provides shortcuts 
such as the <O> and <R><Q> shortcuts, which can save time.

! Exercise: Place a rotated block using AccuDraw

1 Continuing in the AccuDraw model, select Place SmartLine.

2 Place a line at any angle. The length of the line is not important.

3 Select the Place Block tool from the Tasks dialog.

4 Set the following tool settings:

Method: Orthogonal

Area: Solid

Fill Type: None

5 Snap to the upper right end of the line and, with focus in the AccuDraw 
window, press <O> for Origin. DO NOT enter a data point to accept the 
snap point.

AccuDraw Origin placed at snap point
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6 Press <RQ> to Rotate Quick.

Rotate AccuDraw Axes command and tool setting from RQ

7 Note the prompt in the status bar.

The Rotate Quick shortcut requires you to define the X-axis. 

8 Move the pointer towards the other end of the line and AccuSnap to the 
end. Enter a data point at this location.

The compass has rotated to the angle of the line.

9 Note that you have returned to the Place Block tool.

10 Move the pointer along the X-axis and toward the right and index to the 
negative X-axis, while keeping the Y value zero. Enter a value of 1000 units.

11 Accept with a data point.
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Note that the direction, up and to the right, not the dimension, -X, is the 
important thing to think about in the previous step.

You have now placed the first corner point of the block. It is rotated even 
though the Method was set to Orthogonal.

12 Move in the X direction and enter a value of 750.

13 Move in the Y direction and enter a value of 1000.

14 Enter a data point to accept the 750mm by 1000mm block.

Note: Remember that you want to establish direction, and then distance.
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In the next exercise, you will draw an oval shaped element around a rectangle. 
The only information you have is the minimum clearance distance from the 
rectangle.

! Exercise: Place the rectangle

1 Continuing in the Precision Input with AccuDraw model, select the Place 
Block, with the following tool settings:

Method: Orthogonal

Area: Solid

Fill Type: None

2 Following the status bar prompt, place a vertical block of any size.

! Exercise: Place the oval using AccuDraw

1 Select Place SmartLine.

Read the status bar prompt and note that MicroStation requires a data 
point to define the first vertex. The first vertex will be offset from the top 
right corner of the block. 

2 Move the pointer to the top right corner until you see the AccuSnap X. 
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3 With the focus in the AccuDraw window, press <O> to move the AccuDraw 
compass to this location.

4 Index along the X-axis and enter a distance that is appropriate for the 
current zoom level.

5 Following the status bar prompt, enter a data point to place the first 
vertex of the SmartLine.
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6 Move the pointer downward and press <Enter> to lock the axis.

SmartLock indexed to the nearest axis and locked X at 0

7 Snap to the lower right corner of the block and enter a data point. 

This establishes the length of the line segment.

Dashed line indicates that X is locked at 0

You graphically found the length of the rectangle.

8 With focus in the AccuDraw window, press the <~> key to change the 
Segment Type from Lines to Arcs.

The status bar indicates that you need to define the location of the arc 
center.



Precision Input with AccuDraw 84 Jul-10
Copyright © 2010 Bentley Systems, Incorporated

AccuDraw Shortcuts

9 Move the pointer to the midpoint of the block#s lower edge and enter a 
data point when you see the AccuSnap X.

This becomes the center of the arc.

Place arc center point

Next, you need to define the sweep angle of the arc. 

10 Move the pointer clockwise and sweep through 180 degrees. Enter a data 
point to accept the sweep.

AccuDraw indexing makes 90 degree increments easy to draw

11 Press the <~> key to change the Segment Type to Lines.

12 Move the pointer up to the top of the view and press <Enter> to 
SmartLock.
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13 Snap to the upper left corner of the rectangle and enter a data point to fix 
the length of the line segment.

14 With focus on the AccuDraw window, press <~>to change the Segment 
Type to Arc.

15 Following the status bar prompt, snap to the mid-point of the top of the 
rectangle.

16 Enter a data point to accept this as the location for the center of the arc.
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17 Move the pointer clockwise to draw the 180 degree arc and complete the 
oval.

Pop-up Calculator

The pop-up calculator lets you perform mathematical operations. Activated it by 
pressing +, -, *, /, =  in AccuDraw's key-in fields and fields such as Angle or Scale.

Using the pop-up calculator

You can invoke the pop-up calculator in two different modes. The first method 
applies the mathematical expression to the existing value displayed in the field 
with focus. To activate this mode, press either <+>,< ->, <*>, or </>.

The second mode is activated by the <=> key and replaces the existing value with 
the results of a keyed in expression or calculation. In this mode, the result 
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dynamically updates in the original field, rather than having a field of its own in 
the pop-up. This feature is usually used for expressions that are more complex.

Let#s see how you might use MicroStation#s pop-up calculator in everyday drawing 
tasks. 

! Optional Exercise: Use the pop-up calculator

1 Continuing in the Precision Input with AccuDraw model, select Place 
SmartLine, with the following tool setting:

Segment Type: Lines

2 Following the status bar prompt, place the first vertex anywhere in the 
view.

3 Index to the X-axis and press <Enter> to SmartLock.

4 Enter 1500 in the X field.

5 Press the / key to open the pop-up calculator in the division function.
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6 Type 7 into the calculator field.

The result is shown numerically and graphically

7 Enter a data point to accept the second vertex.

8 Index to the Y-axis.

9 Type 750 into the Y field.

10 Press the <*> key to open the pop-up calculator in the multiplication 
function.

11 Type 1.375 into the calculator field and accept the resulting value with a 
data point.
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There are other uses for the pop-up calculator, such as finding a distance halfway 
between two objects.

! Optional Exercise: Find a distance using the pop-up calculator

1 Continuing in the Precision Input with AccuDraw model, select Place 
SmartLine. 

2 Place the first vertex anywhere.

3 Index to the X-axis and enter a second data point anywhere along the X-
axis.

4 Draw another line below the first one.

5 Select the Place Circle tool from the Tasks dialog, with the following tool 
settings:

Method: Center

Area: Solid

Fill Type: None

You are prompted to enter the center point of the circle.

6 AccuSnap to the right end of the upper line.

7 With focus in the AccuDraw window, press <O> to set the origin at the 
snap point.

8 Snap to the left end of the lower line.

9 Press the space bar to switch to Polar mode.
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The Distance field displays the linear distance from the origin to the 
current location of the pointer.

10 Press </> and type 2 in the calculator field. 

This divides the distance by two.

11 Accept the circle center point with a data point.

12 Following the status bar prompt, type a radius of 100 and accept with a 
data point.

Tips and Tricks

$ You can change AccuDraw to use N and E (Northings/Eastings). Select Utilities 
> Key-in to open the Key-in browser. Type ACCUDRAW SETTINGS NORTHEAST 
and press Enter. To switch back to X/Y, type ACCUDRAW SETTINGS XY.

$ Remember that there is more than one way to move the focus to the 
AccuDraw window. You can move the focus by pressing the F11 key, or the 
space bar. 

$ To change the color of the AccuDraw compass, select Settings > AccuDraw and 
click the Display tab. Color options are on the left side of the dialog. The 
Dialog Size option sets the size sets the width of the AccuDraw window.


